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Proprietary Information 

 

This document contains proprietary information that is sensitive to the 

commercial interests of Cambridge Pixel Ltd. The contents of this document 

should not be communicated to third parties without the prior written 
consent of the Company. 
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Change History 
 

The following list describes the changes between successive versions of this 

document. 

 

Version: Date: Comments: 

V1.0 July 2020 First release. 

V1.84.8 August 2020 Add support for thermal-only cameras. 

Add Reset Background Image feature. 

Updated Settings options. 

Updated Setup Wizard. 

Minor wording changes. 
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1. Introduction 
 

This document describes the user interface features of the ETS Fever Detection 

Application and explains how to perform temperature scans. 

 

Section 2 provides an overview of functionality. 

 

Section 3 covers installation. 

 

Section 4 covers configuration. 

 

The user interface is described in section 5. 

 

Sections 6 and 7 describe day-to-day and administration tasks. 

 

Keyboard shortcuts are listed in Appendix A and a disclaimer for the use of the 

software is in Appendix B. 
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2. Overview 
 

The ETS Fever Detection Application is a full-screen application that displays 

video and thermal video, overlaid with person detection and temperature data. 

 

Figure 1 – ETS Fever Detection Application 
 

Its purpose is to scan people for an elevated facial or body temperature (fever), 

which is one of the primary symptoms of Covid-19 and some other communicable 

diseases. 

 

The application recognises the presence of a human face and scans that area for 

a heat reading. If the heat exceeds the threshold that has been set, an alarm is 

generated and a red box is displayed around the person’s face. 

 

This system should be regarded as a first-line preliminary check before more 

detailed medical testing is deemed to be necessary. 

 

The typical fever detection set-up involves the following items: 

 

 A laptop or other PC running the ETS application. 
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 A combined thermal imaging camera and daylight camera (such as 

Silent Sentinel’s Fixed Modum camera), or a thermal-only camera. This 

is usually installed in an indoors location where ambient heat and light 

can be controlled. 

The Fixed Modum camera has an accuracy to 0.3° C. 

 

 
 

Note: The daylight camera and thermal camera have different resolutions 

and aspect ratios. This is the reason why the different video feeds 

may look mismatched when displayed together on-screen. 

 

 A thermal blackbody unit, which provides a constant, unchanging 

source of heat for reference purposes and calibration. This should 

ideally be situated near the subject’s head and pointed directly 

at the thermal imaging camera (it must be within the camera’s 

Field of View). 

 

 
 

The thermal blackbody self-regulates its surface to 35° C. On the rear 

of the blackbody is a temperature display: 

 
 

Please see the documentation for the camera and blackbody unit for set-up 

information. 

 

Note: For best results, the blackbody unit should be positioned approximately 2 

metres away from the camera. The distance should be measured and input 

as the “Reference Range” in the Settings dialog (see “Settings” on page 25 

for further information). 
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2.1. Typical standalone deployment scenario 
 

A typical standalone fever monitoring setup is shown below: 

 

2.2. Networked deployment scenario 
 

In a scenario where the system is networked across a site, multiple cameras can 

be deployed at different locations (each camera having its own accompanying 

blackbody unit). The cameras are then linked to a remote centre via Ethernet. 

 

 

 

Computer + ETS Camera Blackbody Unit 

Ethernet 

Computer + ETS Camera Blackbody Unit 

Ethernet 
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3. Installation 
 

This chapter describes how to install and run the application on a new system. 

 

3.1. System Requirements 
 

The application should be installed on a system meeting the following 

requirements: 

 

Operating System: Windows 10 

Minimum Processor: Intel i5 

CPU bench mark score: >7500 

Screen Resolution: UHD. Minimum 1080 vertical pixels 

(e.g. 1920 x 1080 or higher). 

Memory: 8 GB RAM minimum. 

 

3.2. Installing the Software 
 

The application is normally supplied on a CD-ROM or electronically as a zip file. 

 

The application can be installed on a suitable system by copying the contents of 

the CD-ROM or the unpacked zip file to a directory on the target system. 

 

3.3. Running the Software 
 

After installation and configuration, the application may be started in the same 

way as any other Windows executable - for example, from a command prompt, or 

by double-clicking on the executable or a shortcut to it, or by configuring 

Windows to automatically start the application when an appropriate user logs in. 

The following executables are provided: 

 

 64-bit executable: SPxETS_64.exe 

 32-bit executable: SPxETS.exe 

 

The following warning from Windows Firewall may be displayed when running the 

software for the first time: 
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Figure 2 – Windows Firewall message 
 

Check the checkboxes and click on Allow access to proceed. This message will 

not be displayed again. 

 

If starting the application for the first time after installation, a message may also 

be displayed to prompt you to run the Setup Wizard. 

 

Running the Setup Wizard is the next stage in setting up the ETS application (see 

“Configuration” on page 19). 

 

Each time the application is started, a disclaimer message will be displayed: 

 

Figure 3 – Disclaimer message 



Cambridge Pixel Ltd. P455 Fever Detection Application (ETS) Page 17 

Click OK to proceed. 

 

The full text of this message is in Appendix B. on page 51. Note that this 

disclaimer message can be disabled, if it is not appropriate for the jurisdiction in 

which the software is being used. 
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4. Configuration 
 

This section is for use by Admin and configuration staff. 

 

4.1. Separate modes of operation for maintainers/installers and 
operators 

 

ETS has separate modes of operation for staff who are maintainers/installers of 

the software (Admin), and staff who are ordinary users (i.e. Operators). This 

allows a separation of access to functionality, which is intended to avoid the 

possibility of ordinary operators accidentally changing the settings of the 

software. 

 

This separation between Admin mode and Operator mode is enforced by means 

of a password. 

 

When you install ETS for the first time, it will be in Standard mode by default, so 

you must log in to Admin mode to set a new password. 

 

There are 2 modes of operation for the application: 

 

 Standard – this is the mode used by operators. This is usually set as 

the default when the application is started. 

 Admin – this mode allows admin and configuration staff to set up and 

tune the settings. 

 

Admin mode allows certain settings to be made (the Region of Interest and 

Blackbody Edit options can be set while logged into Admin mode). During normal 

daily operation, the Admin options are typically not available to standard users, 

who will simply be operating the application. 

 

The menu bar at the top of the window is only visible while logged in to Admin 

mode. 

 

4.1.1. Logging into Admin mode 

 

Click the Admin button or press Ctrl + A keys to log into Admin 

mode. Enter a password in the pop-up dialog (the default 

password supplied with the application is “admin”, but you can 

replace it with a password of your own): 
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4.1.2. Setting an Admin password 

 

An Admin user can set up a password for access to the Admin mode. 

 

Use the File > Set Admin Password… menu option to open the Enter New 

Password dialog:

 
Figure 4 – Enter New Password dialog 

 

Type in a new password and click on OK. Use the File > Save menu option or 

click the Save button to save the SPxETS.rpi file. 

 

4.1.3. Logging out of Admin mode 

 

To log out of the Admin mode and continue using the software as 

a standard user, click the Admin button or use the File > Leave 

Admin Mode menu option. 

 

4.2. Using the Setup Wizard 
 

Maintainers/installers only 

 

A setup wizard is provided to make configuration of your camera and blackbody 

easier. This is only accessible while in Admin mode. 

 

Use the File > Setup Wizard… menu option to start the wizard. 

 

Figure 5 – Setup wizard introduction 
 

Click on Next to proceed to the next screen. 
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Figure 6 – Initial Options 
 

This screen allows you to specify whether ETS will appear in full-screen mode on 

startup. 

 

Click on Next to proceed to the next screen. 

 

Figure 7 – Camera 
 

This screen allows you to select the camera type and model. Available types of 

camera are: 

 

 Daylight and Thermal 

 Thermal only 

 

Note: If configured for “Thermal only”, this will only display options for a 

thermal camera in the main window. Buttons that are used to 

display thermal and daylight video in various configurations will 

not be shown in the bar at the bottom of the screen. 

 

Available models are: 

 

 FD384H 

 FD640H 

 

Click on Next to proceed to the next screen. 
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Figure 8 – Video 
 

This screen allows you to specify the IP address of the daylight camera. 

 

Click on Next to proceed to the next screen. 

 
 

This screen allows you to specify the IP address of the thermal camera. 

 

Click on Next to proceed to the next screen. 

 

Figure 9 – Blackbody 
 

This screen allows you to enable or disable the use of a blackbody unit as a 

continuous temperature reference. 

 

Click on Next to proceed to the next screen. 
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Figure 10 – Face Detection 

This screen allows you to enable or disable audible alarms. 

 

Click on Next to proceed to the next screen. 

 

Figure 11 – Modbus 

This screen allows alarms to be output to a Modbus-based alarm system. 

The feature can be enabled or disabled with the check box. 

IP Address, Port and Coil settings for the Modbus system can be input here. 

An alarm duration can be entered with the On time control. 

 

Click on Next to proceed to the next screen. 
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Figure 12 – EdgeVis 

This screen allows video output that results from an alarm to be sent to an 

EdgeVis video streaming system. An EdgeVis system allows multiple video 

streams to be managed and recorded at an optimised speed. 

The feature can be enabled or disabled with the check box. 

IP Address, Port and Password settings for the EdgeVis system can be input 

here. 

 

Click on Next to proceed to the next screen. 

 

 

Figure 13 – Finish screen 
 

This screen will be displayed when you have finished using the wizard for 

configuration. 

 

Click on Finish to close down the wizard. 

ETS will prompt you to save and restart ETS in order to use the new settings: 
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Figure 14 – Restart message 
 

Click on Yes. The ETS application will restart, applying the new settings. 

 

4.3. Settings 
 

In Admin mode, various settings can be made for the following features: 

 

 Alarms 

 Logging 

 Temperature ranges and alarm temperature 

 Face detection 

 Temperature Units 

 

Open the Settings dialog by clicking the Settings button or using 

the Tools > Settings… menu option. 

 

4.3.1. Alarms 

 

Figure 15 – Settings dialog (Alarms tab) 
 

In the Audible Alarms section, an audible alarm or audible “all clear” can be 
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enabled or disabled. If enabled, an alarm/all clear sound will be emitted from the 

attached PC or laptop, or from a suitably-configured Modbus alarm system. 

An alarm is triggered when the temperature is exceeded. An “all clear” is 

triggered when a face is detected that is below the temperature threshold. 

 

The Logging section has options that specify whether to log alarms or all 

detections to disk. The Save Snapshots To Disk setting enables/disables the 

saving of snapshots to disk. 

 

If these options are used, alarms and detections are saved in log files (these are 

.csv files and can be opened with a spreadsheet application such as Microsoft 

Excel). Snapshots are saved in .jpg format and are stored in a sub-folder called 

Snapshots. Each snapshot’s filename contains the date and time so that it can be 

cross-checked with events in the log files. 

 

A temperature range can be defined with the Min and Max controls in the 

Temperatures section. The temperature threshold for an alarm to be triggered is 

set with the Alarm control (i.e. this is the body temperature of a healthy person). 

 

In the Face Detection section, the Processing Interval and Minimum 

Confidence control the face detection tolerances. 

Processing Interval sets the number of frames between which the detection 

algorithm will scan a human face (e.g. 8 means every 8th frame – this controls 

CPU loading). Minimum Confidence sets the threshold for confidence that a 

human face has been correctly detected (typically, this is set to 0.25 and should 

not need to be changed). 

 

4.3.2. Misc 

 

Figure 16 – Settings dialog (Misc tab) 
 

This tab is used to make a variety of settings that are used throughout the 

application. 
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The Temperature Units section allows you to specify the temperature units that 

will be used throughout the application (Metric or Imperial). This controls how the 

temperature is displayed on-screen. 

 

The Display Options section sets various options for text that is displayed on-

screen: 

 

 Temperatures – this checkbox enables or disables the display of a 

temperature above the detection box. 

 Confidences - this checkbox enables or disables the display of a 

“confidence percentage” below the detection box. The confidence 

percentage indicates the level of certainty that a face has been 

correctly detected. 

 Dimensions - this checkbox enables or disables the display of the 

box’s dimensions. This is useful for calibration purposes. 

 Font Size - this control allows you to specify the size of the text used 

to display the temperature and confidence figures. 

 

The Reference Range control allows you to input the measured distance 

between the blackbody unit and the camera (2 metres is a guideline distance to 

use). The distance is also displayed in feet and inches when the setting is 

changed. 

 

In the Blackbody section, the Standard deviation control for the blackbody 

allows you to input a margin of error for temperature variations (if it is known). 

The Temperature control allows the expected temperature of the blackbody unit 

to be set (i.e. set this to the same temperature). 

 

Non-Uniformity Correction (NUC) adjusts for minor detector drift (in the thermal 

camera) that occurs as the scene and environment change. The NUC Auto 

checkbox enables or disables this feature. A refresh interval (i.e. the time 

between refresh operations) can be set with the NUC Interval control. When a 

refresh occurs, the video stream may freeze temporarily. 

 

4.4. Setting the blackbody unit’s scanning position 
 

The blackbody’s scanning position can be defined by drawing a box on-screen. 

This should only need to be set (or re-set) occasionally. 

 

Log into Admin mode and change the video display to the thermal 

camera (using the Thermal button). 

Ensure that the BB button is selected and click the BB-E button.  

 

With the mouse, draw a box in the area of the screen where the blackbody’s heat 

emitter is located (example in following picture). 

Detection box 

Temperature 

Confidence percentage 

Cross indicates position 
of highest temperature 
sampling point 
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Draw the box so that it is centred on the heat emitter. 

 

Note: Do not draw the box to the edge of the emitter’s area (it is cooler 

at the edges, so may give an incorrect reading). 

 

The box should correctly display the blackbody’s temperature and be coloured 

pink. If it displays red, an error has occurred – so click the Error button and 

redraw the box. See also “Blackbody errors” on page 48. 

 

Click the BB-E button again to exit the editing mode. 

 

Change the video display to the daylight camera. 

You may notice that the blackbody unit’s scanning position is not in the correct 

position over the blackbody’s heat emitter, when viewing daylight video. This is 

because the thermal camera and daylight camera do not have the same aspect 

ratio or resolution and are not always aligned perfectly. 

 

Because of this video mismatch, you will need to adjust the box’s 

position using the Nudge feature. Toggle the Nudge button to 

display (or hide) the positioning options. 

Click the buttons repeatedly to move the box into position using 

small increments, until it is correctly positioned over the 

blackbody’s heat emitter. 

L = nudge left, R = nudge right 

U = nudge up, D = nudge down 

 

 

4.5. Setting the Region Of Interest (ROI) 
 

The Region Of Interest is a defined area of the camera’s Field of View, which is 

where the faces of the scanning subjects will appear (i.e. it is at head height for 

most people). 

 

All items outside the Region Of Interest are not scanned. 

 

The Region Of Interest can be defined by drawing a box on-screen. 

 

In Admin mode, change the video display to the daylight camera. 

Ensure that the ROI button is selected and click the ROI-E 

button. 

With the mouse, draw a box in the area of the screen where the faces will be 

scanned (see the dotted red box in the following example). Draw the box by 

clicking the left mouse button and dragging a red box on-screen. 
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Figure 17 – Drawing the ROI box 
 

The box should be drawn to cover the area where people will pass next to the 

blackbody unit. 

 

Note: Keep the ROI box as small as possible. A larger area requires more 

processing to be performed. 

 

Release the mouse button to finish drawing the box and click on the ROI-E 

button again to exit the editing mode. 

 

Figure 18 – Example of an ROI box in use 
 

4.6. Saving the configuration 
 

To save all settings, log into Admin mode then click the Save 

button or use the File > Save menu option (or press Ctrl + S). 

 

To save all settings and give the configuration file a new name, use the File > 

Save As… menu option or press Ctrl + shift + S. The Save As dialog allows you 

to type in a new name for the file: 
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5. User Interface 
 

The Fever Detection Application runs as a full-screen application. 

 

The layout of the elements within the main window is as follows: 

 

Figure 19 – Parts of the main window 
 

 1 - Left button bar. 

See “Left button bar” on page 32 for details. 

 

 2 - Video pane. 

See “Video pane” on page 33 for details. 

 

 3 – Bottom button bar. 

See “Bottom button bar” on page 34 for details. 

 

 4 – Snapshot browser. 

See “Snapshot browser” on page 36 for details. 

 

 

 

 

  

2 

3 

4 1 
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5.1. Left button bar 
 

The button bar on the left of the window has controls that allow a certain amount 

of configuration to be performed. This button bar is split into 2 parts (top and 

bottom): 

 

Figure 20 – Left button bar (top and bottom) 
 

Note: Some of the following buttons may (or may not) appear in the left button 

bar (according to whether they have been enabled or disabled in the 

configuration file). 

 

Admin – Click this button to log into Admin mode. See “Logging 

into Admin mode” on page 19. 

 

Full – Toggle on to display the full set of on-screen controls or 

toggle off to display a simple set of controls. 

 

Save – Click to save the current configuration (this button is only 

available in Admin mode). 

 

Settings – Click to open the Settings dialog and edit the settings 

(this button is only available in Admin mode). 

 

Error – Click to acknowledge errors. Errors may occur if (for 

example) the blackbody has been obscured or is out of alignment. 

This button is only displayed if an error has occurred (and 

has not yet been cleared). 

 

Nudge – Toggle to display (or hide) the options that allow the 

blackbody detection area to be moved (as part of the blackbody 

calibration process). This button is only available in Admin mode. 

 

Overlay Spot Temperature – Toggle to display or hide temperatures at 

the cursor position (example below). 
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Overlay Faces – Toggle to display or hide detection boxes. 

 

 

Picture in Picture – Toggle to show a picture-in-picture video display. 

This will do nothing if a thermal-only camera is configured. 

 

Caption – Toggle to display or hide the caption for the video feed (such 

as “Thermal” or “Daylight” – example below). If active, the caption is 

displayed at the top of the video display. 

 

 
 

Region of Interest – Click to display or hide the Region Of 

Interest that has been defined. 

 

Region of Interest Edit – Click to edit a region of interest. This 

button is only available when in Admin mode and daylight video is 

displayed. See “Setting the Region Of Interest (ROI)” on page 28. 

 

5.2. Video pane 
 

The main video pane displays a daylight video or thermal video feed from the 

body temperature detection camera. 

 

In a daylight video view, face detection recognises a human face and draws a box 

to establish an area for heat sampling. Each detection box can also display a 

temperature reading and a facial detection confidence percentage (these are 

optional). In a thermal video view, this detection system extends to sense other 

body parts, such as arms and legs (and may consequently display detection 

boxes over those body parts). 

 

The detection boxes can be displayed or hidden by using the Overlay Faces 

button, as mentioned above. The temperatures can be displayed or hidden by 

using the Overlay Spot Temperature button, as mentioned above. 

 

Figure 21 – Example of detection box 
  

Detection box 

Temperature 
(optional) 

Confidence percentage 
(optional) 

Cross indicates position 
of highest temperature 
sampling point 
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5.3. Bottom button bar 
 

The button bar on the bottom of the window has buttons that allow the operator 

to specify the camera display. This button bar is split into 2 parts (thermal 

controls and video display options): 

 

Figure 22 – Thermal controls 
 

Note: Some of the following buttons may (or may not) appear in the bottom 

button bar (according to whether they have been enabled or disabled in 

the configuration file). 

 

Information display – this panel displays the 

currently-set temperature threshold. Operational 

status is also displayed here. 

 

Auto Focus – this button forces the thermal camera to focus 

automatically. 

 

White Hot – this button sets the white pixels in the thermal image to 

represent heat (black and white are the inverse of the ‘Black Hot’ 

setting). See “White Hot” on page 37. 

 

Black Hot – this button sets the black pixels in the thermal image to 

represent heat (black and white are the inverse of the ‘White Hot’ 

setting). See “Black Hot” on page 37. 

 

Colour Palette – this button sets the thermal image to represent heat 

with false colours. See “Colour Palette” on page 38. 

 

Blackbody Display – this button enables or disables the display of the 

blackbody’s detection area in the video window. 

 

Blackbody Edit – this button allows the detection area for the 

blackbody to be edited. This can only be selected when in admin 

mode and thermal video is displayed. 

 

Blackbody Reset – this button allows the currently-saved detection 

area settings for the blackbody to be re-used (if the blackbody’s line of 

sight has been obscured and this has generated an error). This button 

is only displayed if such an error has occurred. 

 

Temperature Compensation – this button allows a temperature 

compensation to be quickly applied. This adds a compensation factor 

to allow for the fact that a human’s core temperature is usually higher 

than skin temperature. 

 

Reset Background Image – this button is only displayed if a 

thermal-only camera is configured (i.e. not a combined 

daylight/thermal video camera). If the operator notices poor 

performance (for example, because a sudden change has 

happened - such as the camera being moved without rebooting or 
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a new object being placed into view), then the Reset B/G button can be used to 

immediately reset the background image. It should only be used with a “clean” 

view (with no people in view, because those people will not be detected). 

 

 

Figure 23 – Video display options 
 

Note: Some of the following buttons may (or may not) appear in the button bar 

(according to whether they have been enabled or disabled in the 

configuration file). These buttons are not available if a thermal-only 

camera has been configured. 

 

Thermal - this button shows only the thermal camera feed in the 

video pane. See “Thermal only” on page 39. 

 

Daylight - this button shows only the daylight camera feed in the 

video pane. See “Daylight only” on page 40. 

 

Side by Side - this button shows both the thermal and daylight 

camera feeds in the video pane. Both video feeds are displayed at the 

same size. This layout does not show the snapshot browser. See 

“Side by side” on page 40. 

 

Dual (Daylight) - this button shows both the daylight and thermal 

camera feeds in the video pane. The daylight video is displayed in a 

larger frame than the thermal video. See “Dual (Daylight)” on page 

41. 

 

Dual (Thermal) - this button shows both the thermal and daylight 

camera feeds in the video pane. The thermal video is displayed in a 

larger frame than the daylight video. See “Dual (Thermal)” on page 

41. 
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5.4. Snapshot browser 
 

When a temperature exceeds the threshold, an alarm 

is generated and the camera takes a snapshot. 

 

All snapshots are stored in the browser on the right 

of the screen. 

 

The list of snapshots can be scrolled a line at a time 

using up and down arrow buttons: 

   

Use the following buttons to jump to the beginning or 

end of the snapshot list: 

   
 

Each line of the list shows a daylight and thermal 

snapshot, along with the date and time and the 

temperature recorded. 

 

Each line in the list is numbered to aid with scrolling 

through the entries. 

 

To see a more detailed view of a snapshot, click on the snapshot thumbnail. This 

will open a larger view (examples below): 

 

Figure 24 – Examples of expanded snapshots – video and thermal 
 

These expanded snapshot windows can be dragged into a different position or 

onto another screen (if one is attached to the PC). The snapshot window can be 

closed by clicking on the “X” button. 

 

Occasionally, you may need to clear the pictures out of the snapshot browser to 

start a fresh scanning session. Using the Tools > Clear Thumbnails menu 

option or pressing Ctrl + T will clear the old pictures from the snapshot browser. 
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5.5. Thermal controls 
 

5.5.1. White Hot 

 

Using this setting, the white pixels in the thermal image represent heat. This is 

the default setting. 

 

Click the button to switch the thermal video to “white hot” (see 

following example). 

 
 

5.5.2. Black Hot 

 

Using this setting, the black pixels in the thermal image represent heat. 

 

Click the button to switch the thermal video to “black hot” (see 

following example). 
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5.5.3. Colour Palette 

 

A false colour thermal display can be displayed to aid in inspection of thermal 

video. 

 

Click the button to switch the thermal video to false colour (example 

below). 

 
 

5.6. Video layouts 
 

There are various options for displaying video panes on the screen: 

5.6.1. Picture-in-Picture 

 

A picture-in-picture display shows the currently-selected primary video type with 

the other in a much smaller overlaid video pane. 

 

Note: This button will do nothing if a thermal-only camera has been 

configured. 

 

Click the  button to toggle the picture-in-picture display on or off. 

 

The following example shows the thermal video feed in the main video pane, 

while the daylight video is displayed in the smaller secondary video pane 

(outlined in green). 
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5.6.2. Thermal only 

 

Click the Thermal button to display only the thermal video feed in 

the main video window. 

 

 
 

Note: This is not available if a thermal-only camera has been configured. 
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5.6.3. Daylight only 

 

Click the Daylight button to display only the daylight video feed in 

the main video window. 

 

 

Note: This is not available if a thermal-only camera has been configured. 

 

5.6.4. Side by side 

 

Click the Side by Side button to display both the thermal and 

daylight video feeds in the main video window. The video panes are 

displayed in a side by side arrangement. 

 
 

Note: This is not available if a thermal-only camera has been configured. 
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5.6.5. Dual (Daylight) 

 

Click the Dual (Daylight) button to display both the thermal and 

daylight video feeds in the main video window. The daylight video is 

displayed in the main window, while the thermal video is displayed 

in a smaller secondary window. 

 

Note: This is not available if a thermal-only camera has been configured. 

 

5.6.6. Dual (Thermal) 

 

Click the Dual (Thermal) button to display both the thermal and 

daylight video feeds in the main video window. The thermal video is 

displayed in the main window, while the daylight video is displayed 

in a smaller secondary window. 

 

Note: This is not available if a thermal-only camera has been configured. 
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6. Daily operation 
 

This section discusses the regular daily tasks that an operator (i.e. non-Admin 

user) would typically use during a session. 

 

6.1. Set the window to display full-screen 
 

Press F11 to toggle the full-screen window size on or off. 

 

Note: This can be set as a default window size in Admin mode, using the 

Setup Wizard. 

 

6.2. Choose the user interface 
 

An operator can choose between different user interfaces: 

 

 Full – this displays all buttons on-screen. 

 Simple – this is a simplified user interface with fewer buttons. 

 

Toggle the Full button to show all buttons or a simplified view, according to the 

operator’s personal preference. 

 

6.3. Choose the video type and layout 
 

During the course of a session, it may be necessary to change the video screen 

layout and type of video displayed. This is the personal choice of the operator. 

 

A typical operator may use the full-sized daylight camera as the main viewing 

setup, occasionally flipping to the thermal camera if required. 

 

Please refer to “Thermal controls” on page 37 and “Video layouts” on page 38 for 

further details. 

 

6.4. Watch the screen and respond to alarms 
 

As people walk in front of the camera, a detection box should be displayed around 

each person’s face. 

 

A green detection box is displayed if the subject’s body temperature is below the 

threshold that has been set. 

 

A red detection box is displayed if the subject’s body temperature exceeds the 

threshold that has been set. This will trigger an alarm and add daylight and 

thermal snapshots to the snapshot browser. Depending upon the configuration of 

the application, the alarm may also be audible. 

 

As the operator, you may need to ask a subject to step aside for more detailed 

health analysis if they have triggered an alarm. 
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Figure 25 – Example of green and red detection boxes 
 

The camera reads skin temperature, but the software compensates for the fact 

that this is lower than body temperature. Compensation can be toggled on or off 

using the Comp button if a skin temperature reading is required. 

 

6.5. Log a message 
 

During the course of a typical day, you may need to make notes and observations 

on what is happening. Press the Ctrl + L keys to enter a text message. 

 

See “Logging a message” on page 47 for further details. 

 

6.6. Handle snapshots 
 

During the course of a session, the system may record snapshots of faces that 

register a temperature above the threshold that has been set. 

 

Please refer to “Snapshot browser” on page 36 for full details of using the 

snapshot browser. Snapshots are stored as .jpg files in the Snapshot sub-folder 

where the application is installed. 

 

6.7. Clear Thumbnails 
 

Occasionally, you may need to clear the pictures out of the snapshot browser to 

start a fresh scanning session. 

 

Pressing Ctrl + T will clear the old pictures from the snapshot browser. 
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6.8. Screen Grab 
 

You may need to quickly take a screenshot of the video screen, to record a 

picture of the whole scene, including on-screen temperature measurements. 

 

Press Ctrl + G to perform a screen grab. 

 

Screen grabs created this way are saved as .jpg (JPEG) files in the application’s 

installation folder. Each file has the time and date recorded in the filename. 

These images are not displayed in the snapshot browser. 

 

6.9. Handle an error 
 

An error may occur occasionally, most likely as a consequence of the blackbody 

unit being obscured (or in some cases, it may have moved). 

 

If a blackbody error has occurred because its line of sight has been 

obscured, but the relative positions of the blackbody and camera have 

not changed, click on the BB-R (Blackbody Reset) button. This will use 

the same settings as before and there will be no need to redraw and 

reposition the blackbody detection area. 

An Error button will be displayed on the left button bar if an error has occurred 

(and has not yet been cleared). 

 

Press F8 to display the Messages window. This may provide useful information 

about the error that has occurred. See “Messages window” on page 47 for further 

details. 

 

Click the Error button (or press Ctrl + E) to acknowledge the error and continue 

with scanning. If a problem persists, it may be necessary to get an Admin user to 

reset the settings for the blackbody unit (see “Blackbody errors” on page 48 and 

“Setting the blackbody unit’s scanning position” on page 27 for further details). 

 

When using a thermal-only camera, if there is poor performance 

(for example, because a sudden change has happened - such as 

the camera being moved without rebooting or a new object 

being placed into view), click the Reset B/G button to 

immediately reset the background image. 

Note that it should only be used with a “clean” view (with no people 

present, because those people will not be detected). 

 

6.10. Messages 
 

You may wish to look at a list of alarms that have been generated, or view 

system-generated messages that may contain information about the application’s 

functioning status (perhaps to aid in a support call). 

 

Press F8 to open the Messages window. 

 

For further information, see “Messages window” on page 47. 
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7. Admin tasks 
 

This section discusses various regular admin tasks that an administration user will 

need to perform. 

 

7.1. Messages window 
 

To see any system-generated messages that may contain information about the 

application’s functioning status, use the View > Message Window… menu 

option (or press F8) to open the Messages window: 

 

Figure 26 –Messages window 
 

This window displays the following types of messages: 

 

 Software version number 

 Licence ID 

 Admin mode entry or exit 

 System error messages 

 Errors with blackbody setup 

 Alarms triggered by high temperature readings 

 

To clear any old messages from the list, click the Clear Buffer button. 

 

To freeze the message display if messages are scrolling past, check the Freeze 

Window checkbox. 

 

7.2. Logging a message 
 

During the course of a typical day, you may need to make notes and observations 

on what is happening. 

 

To log a message, select the Tools > Log Message… menu option, or press the 

Ctrl + L keys. This opens a Log Message dialog: 
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Type in the message you wish to record and click OK. 

 

7.3. Blackbody errors 
 

Occasionally, there may be circumstances when the blackbody unit becomes 

obscured or its temperature cannot be detected by the thermal camera. 

 

In such circumstances, an error message will be displayed on-screen: 

 

When this message is displayed, the blackbody detection area will need to be 

reconfigured. Also, a member of staff should ensure that the blackbody unit itself 

is switched on, is pointing directly at the camera and is not obscured. 

 

If a blackbody error has occurred because its line of sight has been 

obscured, but the relative positions of the blackbody and camera have 

not changed, click on the BB-R (blackbody reset) button. This will use 

the same settings as before and there will be no need to redraw and 

reposition the blackbody detection area. 

 

In the event of an error occurring, an Error button will be 

displayed. Click the button (or use the Tools > Clear Error menu 

option if in Admin mode) to acknowledge the errors. 

 

See also “Setting the blackbody unit’s scanning position” on page 27. 

 

7.4. Screen Grab 
 

You may need to quickly take a screenshot of the video screen, to record a 

picture of the whole scene, including on-screen temperature measurements. 

 

Use the Tools > Grab Screen menu option or press Ctrl + G to perform a screen 

grab. 

 

Screen grabs created this way are saved as .jpg (JPEG) files in the application’s 

installation folder. Each file has the time and date recorded in the filename. 

These images are not displayed in the snapshot browser. 
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Appendix A.  Shortcuts 
 

The following table lists the keyboard shortcuts that have been assigned in the 

application: 

 

In standard user mode: 

 

Description or Function Keys 

Clear Error Ctrl + E 

Clear Thumbnails Ctrl + T 

Enter Admin Mode Ctrl + A 

Exit application Alt + F4 

Full Screen on/off F11 

Grab screen Ctrl + G 

Log Message Ctrl + L 

Message Window F8 

View Help F1 

 

 

In admin user mode: 

 

Description or Function Keys 

Camera Config Ctrl + shift + C 

Clear Error Ctrl + E 

Clear Thumbnails Ctrl + T 

Exit application Alt + F4 

Full Screen on/off F11 

Grab Screen Ctrl + G 

Log Message Ctrl + L 

Message Window F8 

Parameter Control Ctrl + P 

Save Ctrl + S 

Save As Ctrl + shift + S 

Settings F7 

Setup Wizard Ctrl + W 

Video Input Config Ctrl + shift + V 

View Help F1 
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Appendix B.  Disclaimer 
 

The following is the disclaimer text displayed at startup: 

 

WARNING REGARDING CONDITIONS OF USE 
 

This Device is not FDA cleared or approved for medical diagnosis of 

illness or symptoms of illness. 

 

Device is intended to be used only: 

 

i. for triage purposes to perform initial body temperature 

measurement. 

 

ii. where an elevated body temperature measurement is confirmed in        

the context of use with secondary evaluation methods (e.g., non-

contact infrared thermometer (NCIT) or clinical grade contact 

thermometer); 

 

and 

 

iii. where such devices do not create an undue risk in light of the 

public health emergency. 

 

Per U.S. Food and Drug Administration ("FDA") guidance ("Enforcement 

Policy for Telethermographic Systems During the Coronavirus Disease 2019 

(COVID-19) Public Health Emergency" (April 2020)): 

 

i. the Device should not be solely or primarily relied upon to diagnose 

or exclude a diagnosis of COVID-19, or any other disease. 

 

ii. public health officials, through their experience with the Device in 

the particular environment of use, should determine the 

significance of any fever or elevated temperature based on the skin 

Telethermographic temperature measurement. 

 

iii. the system and technology should be used to measure only one 

subject's temperature at a time; 

 

and 

 

iv. visible thermal patterns are only intended for locating the points 

from which to extract the thermal measurement. 
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Displaying or hiding this message 
 

Admin and configuration staff only 

 

The disclaimer popup can also be displayed by entering Admin mode and using 

the Help > Disclaimer… menu option. 

 

To turn the popup message off, edit the SPxETS.rpi configuration file to the 

following setting: 

 
Application.ShowDisclaimer = 0 

 

To turn the popup message on, edit the SPxETS.rpi configuration file to the 

following setting: 

 
Application.ShowDisclaimer = 1 
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